Sentinal Application SLowness

Incident Report for Kajeet

Resolved

Sentinel service performance has returned to normal after the internal ThousandEyes monitoring transaction testing Sentinel UI login was stopped at approximately 07:53 EDT. We are continuing to monitor to confirm stability.

If you experience further technical difficulties, please reach out to our customer support team at support@kajeet.com, online at Support.Kajeet.com, or call 1 (877) 352-5338 to speak with someone right away.
Posted Jul 15, 2026 - 08:28 EDT

Investigating

We are investigating an issue affecting Sentinel, including Sentinel App access and related processing. Teams are actively working on database performance concerns and will provide another update once impact and mitigation are confirmed.
Posted Jul 15, 2026 - 06:52 EDT
This incident affected: REST APIs.