Verizon Wireless device activations

Incident Report for Kajeet

Resolved

Resolved: Verizon Wireless device activations are completing successfully. We will continue working with Verizon to review the incident and monitor service.

Thank you for your patience while we worked to restore service. If you continue to experience any issues submitting a support request, please contact Kajeet Support at support@kajeet.com or 877-352-5338.
Posted Aug 13, 2026 - 18:45 EDT

Investigating

We are investigating an issue affecting Verizon Wireless device activations. Activation attempts may fail while we work with the carrier to determine scope and restore service.
Posted Aug 13, 2026 - 16:48 EDT
This incident affected: Self Service Activations.