Kajeet Customer Support 800 Number Outage 2/4/2026

Incident Report for Kajeet

Resolved

This issue has resolved and normal performance levels have been restored.

Thank you for your continued patience. If you experience further technical difficulties, please reach out to our customer support team at support@kajeet.com, online at Support.Kajeet.com, or call 1 (877) 352-5338 to speak with someone right away.
Posted Feb 04, 2026 - 12:59 EST

Investigating

We are currently experiencing a temporary outage with our phone systems and are unable to receive inbound support calls at this time.
Our team is actively working to resolve the issue. In the meantime, customers can reach Support through the following channels:

Submit a case via Sentinel
Email us at support@kajeet.com
Visit kajeet.com and use the chat feature

We appreciate your patience and will provide updates as more information becomes available.
Posted Feb 04, 2026 - 09:08 EST
This incident affected: Kajeet Support Phone Line.