Blocked Traffic due to a Content Filtering Issue

Incident Report for Kajeet

Resolved

As of Monday 3/24/25 5:28 PM ET, the blocked traffic issues have been reolved.

Thank you for your continued patience as our team worked to resolve this issue. If you experience further technical difficulties, please reach out to our customer support team at support@kajeet.com, online at Support.Kajeet.com, or call 877-352-5338 to speak with someone right away.
Posted 12 days ago. Mar 24, 2025 - 17:36 EDT

Investigating

As of 12:20 PM ET, some customers may be experiencing blocked traffic due to a content filtering issue.

Please know our team is actively working on identifying and resolving this issue and we apologize for any inconvenience this might have caused.
Posted 12 days ago. Mar 24, 2025 - 15:56 EDT
This incident affected: Wireless Connected Devices.