Verizon Activations Issues

Incident Report for Kajeet

Resolved

Verizon has resolved the issue and activations via our self service activation functionality in Sentinel have returned to normal.

If you experience further technical difficulties, please reach out to our customer support team at support@kajeet.com, online at Support.Kajeet.com, or call 240-482-4636 to speak with someone right away.
Posted Sep 20, 2023 - 15:22 EDT

Investigating

Customers attempting Verizon activations via our self service activation functionality in Sentinel may encounter errors. We've engaged Verizon support who are actively working to fix the issue.
Posted Sep 20, 2023 - 11:50 EDT
This incident affected: Wireless Connected Devices, Management Portal, Reporting, and REST APIs.