Delayed AT&T Activations

Incident Report for Kajeet

Resolved

The AT&T activations issue has been resolved and normal performance levels have been restored.

Thank you for your continued patience as our team worked to resolve this issue. If you experience further technical difficulties, please reach out to our customer support team at support@kajeet.com, online at Support.Kajeet.com, or call 240-482-4636 to speak with someone right away.
Posted Apr 11, 2025 - 10:22 EDT

Update

AT&T continues to investigate the delay in Activations.
Posted Apr 10, 2025 - 23:50 EDT

Investigating

Some customer may be experiencing delayed AT&T actvations.

Please know our team is actively working with AT&T on identifying and resolving this issue and we apologize for any inconvenience this might have caused.
Posted Apr 10, 2025 - 17:36 EDT
This incident affected: Self Service Activations.