Verizon Activations Issues 3/9/2026

Incident Report for Kajeet

Resolved

This issue has resolved by Verizon and normal performance levels have been restored. Thank you for your continued patience.

If you experience further technical difficulties, please reach out to our customer support team at support@kajeet.com, online at Support.Kajeet.com, or call 1 (877) 352-5338 to speak with someone right away.
Posted Mar 10, 2026 - 09:18 EDT

Investigating

Some customer may be experiencing issues with Verizon activations. Our engineers are working with Verizon's engineers to resolve this issue, however we expect there to be delays for any new Verizon activations.
Posted Mar 09, 2026 - 20:39 EDT
This incident affected: Self Service Activations.