Verizon Service Level Degredation

Incident Report for Kajeet

Resolved

The Verizon issues have been resolved and normal performance levels have been restored.

Thank you for your continued patience as our team worked to resolve this issue. If you experience further technical difficulties, please reach out to our customer support team at support@kajeet.com, online at Support.Kajeet.com, or call 240-482-4636 to speak with someone right away.
Posted Apr 18, 2025 - 08:41 EDT

Update

Please know that Verizon is working to restore service at normal performance levels. Further updates will be provided as soon as they become available.
Posted Apr 17, 2025 - 18:00 EDT

Identified

Our Verizon Enterprise circuits experienced issues overnight that we've since mitigated. Customers may have experienced degradation of service around 6AM ET. We're actively working with Verizon support to troubleshoot further.
Posted Apr 17, 2025 - 10:30 EDT
This incident affected: Wireless Connected Devices.