T-Mobile Line Deactivations

Incident Report for Kajeet

Resolved

We have identified an issue affecting a subset of T-Mobile lines. Reactivation Has been completed, and we are working with the carrier on root cause.

Thank you for your patience while we worked to restore service. If you continue to experience any issues submitting a support request, please contact Kajeet Support at support@kajeet.com or 877-352-5338.
Posted Aug 21, 2026 - 17:22 EDT

Investigating

We are investigating an issue affecting a subset of T-Mobile lines, which may result in loss of service. We are working with the carrier to confirm the scope and restore affected lines.
Posted Aug 21, 2026 - 16:47 EDT
This incident affected: Self Service Activations.